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Section 1: Overview
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This tutorial provides step-by-step guidance for the sample joist structure. Enough details are 

provided that the example model with non-doubly symmetric sections can be completed following 

the instructions here. Not every feature available in MASTAN2 will be mentioned nor utilized in this 

tutorial. For further information on many of the features within MASTAN2 make use of other 

tutorials at http://www.mastan2.com/tutorial.html. 

Overview

http://www.mastan2.com/tutorial.html
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This tutorial works with a single open-web steel joist. The model will be created to show how to 

analyze a joist for a uniform distributed load on the top chord accounting for the non-doubly 

symmetric section properties. This model will then be adjusted to allow for the application of an 

eccentric point load on the bottom chord. Further details of each model will be provided in the 

corresponding section.

Problem Overview
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Section 2: Getting Started
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MASTAN2 is an interactive graphics program that provides preprocessing, analysis, and postprocessing 

capabilities. Preprocessing options include definition of structural geometry, support conditions, applied loads, and 

element properties. The analysis routines provide the user the opportunity to perform first- or second-order elastic 

or inelastic analyses of two- or three-dimensional frames and trusses subjected to static and dynamic loads. 

Postprocessing capabilities include the interpretation of structural behavior through deformation and force 

diagrams, printed output, and facilities for plotting response curves. MASTAN2 is based on MATLAB®, a premier 

software package for numeric computing and data analysis. 

In many ways, MASTAN2 is similar to today’s commercially available software in functionality. The 

number of pre- and post-processing options, however, have been limited in order to minimize the amount of time 

needed for a user to become proficient at its use. The program’s linear and nonlinear analysis routines are based on 

the theoretical and numerical formulations presented in the text Matrix Structural Analysis, 2nd Edition, by McGuire, 

Gallagher, and Ziemian. In this regard, the reader is strongly encouraged to use this software as a tool for 

demonstration, reviewing examples, solving problems, and perhaps performing analysis and design studies. Where 

MASTAN2 has been written in modular format, the reader is also provided the opportunity to develop and 

implement additional or alternative analysis routines directly within the program. 

MATLAB is a registered trademark of The MathWorks, Inc., 3 Apple Hill Drive, Natick, MA 01760-2098.

MASTAN2 General Information
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Two versions of MASTAN2 have been developed and may be installed. One requires you to have 

access to MATLAB and the other does not. Both versions provide the same functionality, except that 

the MATLAB version also provides the user an opportunity to develop and implement additional or 

alternative analysis routines that will directly interact with MASTAN2. Please see the Setup Guides at 

www.mastan2.com. 

Launching MASTAN2

Start Here

http://www.mastan2.com/
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In order to minimize the learning time for MASTAN2, its graphical user interface (GUI) has been 

designed using a simple and consistent two menu approach. Using a pull-down menu at the top of the 

GUI, a command is selected. Parameters are then defined in the bottom menu bar and the command is 

executed by using the Apply button.

Base Layout

Main model window

Bottom menu bar

Edit Field

Pull-down menu

Submenu

Button
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Section 3: Base Joist Geometry
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While you can build the model and complete the analysis without saving or applying a title, due to the 

complexity of the model we will create a save file immediately. For the remainder of this tutorial, 

there will not be a reminder to save. However, it can be useful to save the file as you go along, 

particularly before any action that is not easily reversed as there is no undo feature. A file can be 

reopened while still working in that file without saving it to revert to the previous save version of the 

model that is unaffected by your last steps. 

1) Start with a new, empty model. 

2) From the File menu select Define title. At the bottom menu bar, click in the edit box to the right of 

Title: and type in a brief description of this effort. This text might include the model title, your 

name, and/or the assignment number. Click on the Apply button.

3) From the File menu select Save As … . After selecting your destination folder, type in the filename 

Joist and click Save. Note that the top of the window has now changed to include the file name and 

directory as well as the time the file was last saved.

Naming and Saving
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The joist will be modeled with the chords as two separate members to allow them to twist 

independently. The geometry could be input by defining individual nodes and then individual 

elements or making use of the extrude element tool extensively. Instead, the Input Geometry tool will 

be used to define most of the joist geometry. As a large part of creating the frame is the prep work, an 

explanation of what values were used is provided on this page and the next pages explain how to use 

the values and links to what the values are. 

The joist was defined as a series of nodes along the top chord and then the bottom chord. The first set 

is for the chords set back in the negative z-direction. The second set is for the chords in the positive z-

direction. The third set is on the x-y plane for member to member connections and the webs. The x 

position was defined based on the simple joist geometry. 

A node is defined for the end of the members, each web intersection, and where the joist bracing 

connects. The y position of the top chord nodes is set as 16” minus the centroid of the top chord angle 

while the bottom chord is 0” plus the centroid of the bottom chord angle. The z position similarly 

accounts for the centroid position plus a 1-1/8” gap between the chords. 

The elements are defined in order to connect all back chords, all front chords, all webs, and then the 

connections in between. 

Defining the Joist
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For entering the node coordinates and element information below, the values are provided in two 

different formats for your use. Node and element information needs to be copied only once.

A - Lists all the node information in separate readable segments to be copied in order.

B - Lists all the element information in separate readable segments to be copied in order.

C - Lists all the node and then all element information in small font lists to be copied all at once.

1) From the Geometry menu select Input Geometry .

2) At the bottom menu bar, Nodes should be already selected. In the edit box to the right of X_coord

Y_coord Z_coord, enter manually or copy and paste the coordinate values.

3) Click on Nodes to open a pop-up menu. Click on Elements to update what information is imported. 

4) In the edit box to the right of Node_i Node_j Beta(deg), enter manually or copy and paste the 

element start and end nodes. When only 2 values are provided, beta is assumed to be 0.

5) Click on the Apply button. 

Note: Apply button could be clicked before defining the Element list to just input the Nodes first. The Element list 

will then use the existing node information on the second use of Apply button.

Defining Geometry
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Copy all 3 tables in order

Nodes 1

0 15.54894 -1.01356
2 15.54894 -1.01356
25 15.54894 -1.01356
40 15.54894 -1.01356
48 15.54894 -1.01356
72 15.54894 -1.01356
96 15.54894 -1.01356
120 15.54894 -1.01356
144 15.54894 -1.01356
168 15.54894 -1.01356
192 15.54894 -1.01356
200 15.54894 -1.01356
215 15.54894 -1.01356
238 15.54894 -1.01356
240 15.54894 -1.01356
26 0.42775 -0.99025
32 0.42775 -0.99025
40 0.42775 -0.99025
72 0.42775 -0.99025
120 0.42775 -0.99025
168 0.42775 -0.99025
200 0.42775 -0.99025
208 0.42775 -0.99025
214 0.42775 -0.99025

Nodes 2

0 15.54894 1.01356
2 15.54894 1.01356
25 15.54894 1.01356
40 15.54894 1.01356
48 15.54894 1.01356
72 15.54894 1.01356
96 15.54894 1.01356
120 15.54894 1.01356
144 15.54894 1.01356
168 15.54894 1.01356
192 15.54894 1.01356
200 15.54894 1.01356
215 15.54894 1.01356
238 15.54894 1.01356
240 15.54894 1.01356
26 0.42775 0.99025
32 0.42775 0.99025
40 0.42775 0.99025
72 0.42775 0.99025
120 0.42775 0.99025
168 0.42775 0.99025
200 0.42775 0.99025
208 0.42775 0.99025
214 0.42775 0.99025

Nodes 3

0 15.54894 0
2 15.54894 0
25 15.54894 0
40 15.54894 0
48 15.54894 0
72 15.54894 0
96 15.54894 0
120 15.54894 0
144 15.54894 0
168 15.54894 0
192 15.54894 0
200 15.54894 0
215 15.54894 0
238 15.54894 0
240 15.54894 0
26 0.42775 0
32 0.42775 0
40 0.42775 0
72 0.42775 0
120 0.42775 0
168 0.42775 0
200 0.42775 0
208 0.42775 0
214 0.42775 0
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1 B. Chord

1 2
2 3
3 4
4 5
5 6
6 7
7 8
8 9
9 10
10 11
11 12
12 13
13 14
14 15
16 17
17 18
18 19
19 20
20 21
21 22
22 23
23 24

2 F. Chord

25 26
26 27
27 28
28 29
29 30
30 31
31 32
32 33
33 34
34 35
35 36
36 37
37 38
38 39
40 41
41 42
42 43
43 44
44 45
45 46
46 47
47 48

3 Webs

50 65
51 65
53 65
53 67
54 67
55 67
55 68
56 68
57 68
57 69
58 69
59 69
59 71
61 71
62 71

4 B. Conn.

50 2
51 3
53 5
54 6
55 7
56 8
57 9
58 10
59 11
61 13
62 14
65 17
67 19
68 20
69 21
71 23

5 F. Conn.

50 26
51 27
53 29
54 30
55 31
56 32
57 33
58 34
59 35
61 37
62 38
65 41
67 43
68 44
69 45
71 47

Copy all 5 tables in order
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Copy all values to 

the Node section

Copy all values to the 

Element section

Elements
1 2
2 3
3 4
4 5
5 6
6 7
7 8
8 9
9 10
10 11
11 12
12 13
13 14
14 15
16 17
17 18
18 19
19 20
20 21
21 22
22 23
23 24
25 26
26 27
27 28
28 29
29 30
30 31
31 32
32 33
33 34
34 35
35 36
36 37
37 38
38 39
40 41
41 42
42 43
43 44
44 45
45 46
46 47
47 48
50 65
51 65
53 65
53 67
54 67
55 67
55 68
56 68
57 68
57 69
58 69
59 69
59 71
61 71
62 71
50 2
51 3
53 5
54 6
55 7
56 8
57 9
58 10
59 11
61 13
62 14
65 17
67 19
68 20
69 21
71 23
50 26
51 27
53 29
54 30
55 31
56 32
57 33
58 34
59 35
61 37
62 38
65 41
67 43
68 44
69 45
71 47

Nodes
0 15.54894 -1.01356
2 15.54894 -1.01356
25 15.54894 -1.01356
40 15.54894 -1.01356
48 15.54894 -1.01356
72 15.54894 -1.01356
96 15.54894 -1.01356
120 15.54894 -1.01356
144 15.54894 -1.01356
168 15.54894 -1.01356
192 15.54894 -1.01356
200 15.54894 -1.01356
215 15.54894 -1.01356
238 15.54894 -1.01356
240 15.54894 -1.01356
26 0.42775 -0.99025
32 0.42775 -0.99025
40 0.42775 -0.99025
72 0.42775 -0.99025
120 0.42775 -0.99025
168 0.42775 -0.99025
200 0.42775 -0.99025
208 0.42775 -0.99025
214 0.42775 -0.99025
0 15.54894 1.01356
2 15.54894 1.01356
25 15.54894 1.01356
40 15.54894 1.01356
48 15.54894 1.01356
72 15.54894 1.01356
96 15.54894 1.01356
120 15.54894 1.01356
144 15.54894 1.01356
168 15.54894 1.01356
192 15.54894 1.01356
200 15.54894 1.01356
215 15.54894 1.01356
238 15.54894 1.01356
240 15.54894 1.01356
26 0.42775 0.99025
32 0.42775 0.99025
40 0.42775 0.99025
72 0.42775 0.99025
120 0.42775 0.99025
168 0.42775 0.99025
200 0.42775 0.99025
208 0.42775 0.99025
214 0.42775 0.99025
0 15.54894 0
2 15.54894 0
25 15.54894 0
40 15.54894 0
48 15.54894 0
72 15.54894 0
96 15.54894 0
120 15.54894 0
144 15.54894 0
168 15.54894 0
192 15.54894 0
200 15.54894 0
215 15.54894 0
238 15.54894 0
240 15.54894 0
26 0.42775 0
32 0.42775 0
40 0.42775 0
72 0.42775 0
120 0.42775 0
168 0.42775 0
200 0.42775 0
208 0.42775 0
214 0.42775 0
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1) From the Geometry menu select Extrude Element.

2) Click on the nodes on the bottom chord closest to the joist bridging connection: Nodes 18, 22, 42, 

and 46 to populate the nodes to be extruded.

3) Click in the edit box to the right of Delta y = and change 0 to 2.5. 

4) Click on the Apply Button.

5) Click on the new nodes above the back, bottom chord to the joist bridging. Depending on the exact 

order you clicked the previous nodes, the node index may vary. 

6) Click in the edit box to the right of Delta z = and change 0 to 0.99025. Increase the Times = from 1

to 2 by clicking on the > button. 

7) Click on the Apply Button.

Note: The elements created in Step 2 will need to be manually selected multiple times through this project. These 4 

elements will be referenced as the vertical braces after this point.

Lower Bridging Support
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1) From the Geometry menu select Subdivide Element(s). The top chord is to be meshed into 

approximately 8” segments. 

2) Click on the 4 top chord sections near the cross-bracing support to be subdivided 2 times.

3) Click on the Apply button.

4) Click the > box to the right of # of Segments = to increase 2 to 3.

5) In the bottom menu bar, use the buttons to the right of Element(s): to make the list of elements to 

be subdivided 3 times.

6) Click the Adv button to open pop-up menu. To select middle of the top chords, click the check box 

next to the X-axis option. Ensure the button to the right of Range (Inclusive) to change Off to On. 

Change the edit box to the left of X from –Inf to 48. Change the edit box to the right of X from Inf to 

192. Change the edit box to the left of Y from –Inf to 8. Click Add to select.

7) Click on the 4 remaining exterior top chord sections to be subdivided 3 times.

8) Click on the Apply button.

Top Chord Meshing
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1) The bottom chord is to be meshed into approximately 4” segments. 

2) Click on the 4-32” long bottom chord elements.

3) Click the > box to the right of # of Segments = to increase 3 to 4.

4) Click on the Apply button.

5) Click on the middle 4 bottom chord elements.

6) Click the > box to the right of # of Segments = to increase 4 to 6.

7) Click on the Apply button.

8) On the Advanced Element Selection pop-up, click the Reset button. Click the check box next to the 

X-axis option. Click the button to the right of Range (Inclusive) to change Off to On. Change the 

edit box to the right of Y from Inf to 8. Click Add to select the entire bottom chord.

9) Click the < box to the left of # of Segments = to decrease 6 to 2.

10)Click on the Apply button.

Bottom Chord Meshing
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1) The web is to be meshed into 4 equal segments. 

2) Click the > box to the right of # of Segments = to increase 2 to 4.

3) On the Advanced Element Selection pop-up, click the Reset button. Click the button to the right of 

Range (Inclusive) to change Off to On. Change the edit box to the left of Z from -Inf to -0.1 and to 

the right of Z from Inf to 0.1. Click Add to select all webs. 

4) Click on the Apply button.

Web Meshing
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1) From the Geometry menu select Remove Node(s).

2) Click on All Unattached to select all unconnected nodes that were included for simplicity in the 

initial model construction.

3) Click on the Apply button to remove. 

The next steps are not required; however, it will help make it easier to find results in the model.

4) From the Geometry menu select Renumber Elements.

5) Click the checkbox to the left of Y-X-Z (2D). Click on the Apply button.

6) From the Geometry menu select Renumber Nodes.

7) Click the checkbox to the left of Y-X-Z (2D). Click on the Apply button.

Model Cleanup
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1) From the Geometry menu select Extrude Element.

2) Click on the node at the middle of the bottom chord where the loading is to be applied. If you 

renumbered the model, this should be Node 167.

3) Click in the edit box to the right of Delta z = and change 0 to 1.5 to define the offset loading 

location.

4) Click on the Apply Button.

Eccentric Loading Location
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The steel joist model uses 6 sections. There is a separate entry for the top chord angle, the bottom 

chord angle, the three different web members, and a rigid link connector. 

The information can be input by 3 methods. If the section properties are all previously calculated, 

values can be entered directly. The information can be input individually via the Define Section

command after switching to the Advanced section properties interface or can be imported as a group 

via the Input Properties command. If the section properties need to be calculated, MSASect can be 

used calculate the information. 

This tutorial will first import all the section property information via the Input Properties command. 

Then it will demonstrate how MSASect could have been used to calculate the same information. The 

top chord angle will be calculated and saved, but not used as part of this analysis. 

Section Properties
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Cross-Section Geometry
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1) From the Properties menu select Input Properties.

2) At the bottom menu bar, Sections should already be selected. Copy and paste the values below into 

the edit box below |Name| Area Izz Iyy J Cw Zzz Zyy Ayy Azz Ysc Zsc BetaV BetaW Betaw Iyz. 

All members are entered in a principal orientation. The letter at the end of the name is to help remember the 

orientation with the corner of the angle members down and the opening of the channels up. 

3) Click on the Apply button. 

The section properties of the rigid element are approximated based on a 2” x 2” solid square as it has 

larger section properties than the majority of the joist elements. Combined with the higher modulus 

of elasticity will provide the effective rigid link. Care must be taken as too stiff of a link can cause 

issues with the solver and too soft will add unintended deformations.

Importing Section Properties

|Top Chord (V)| 0.36199 0.025692 0.13129 2.1666e-3 4.652e-5 0.083769 0.19214 Inf Inf -0.4957 0 0 2.1346 0 0
|Bot Chord (V)| 0.29895 0.01956 0.10058 1.3179e-3 3.4339e-5 0.066516 0.09328 Inf Inf -0.47698 0 0 2.0602 0 0
|Web 1 (U)| 0.29875 0.028641 0.054567 1.317e-3 3.3476e-3 0.081668 0.11919 Inf Inf -0.74007 0 0 1.8413 0 0
|Web 2 (U)| 0.26093 0.021852 0.047564 9.589e-4 2.5185e-3 0.066672 0.10367 Inf Inf -0.68065 0 0 1.7533 0 0
|Web 3 (U)| 0.15847 0.0072663 0.027533 3.1075e-4 7.4428e-4 0.029823 0.060575 Inf Inf -0.46984 0 0 1.4813 0 0
|RIGID| 4 1.33 1.33 2.25 64 4 4 Inf Inf 0 0 0 0 0 0
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1) Outside of MASTAN2, create a text file that summarizes the node and segment data similar to the 

one shown here.

2) From the Properties menu select Define Section.

3) At the bottom menu bar, click on the pop-up menu on the far right that currently displays Basic. 

Click on Advanced.

4) Click on MSASect.

5) After the interface loads, click the radio button next to General.

6) Click Next to open the editable general section interface. 

7) Click Open at the bottom of the screen.  

8) Navigate to the location of the text file. After selecting it, click Open.

9) Click Calculate to determine the properties.

10)Click edit box to right of Name: and enter Top Chord Alt. 

11)Click Export to MASTAN2 to copy values to main program. Click Close to return to main program.

12)Click Apply to save Section 7.

Calculating Section Properties
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Version to Copy for own Text File

Nodes
1,0.000000,-0.000000
2,-0.186234,-0.186234
3,-0.372468,-0.372468
4,-0.558703,-0.558703
5,-0.744937,-0.744937
6,-0.805247,-0.823534
7,-0.843159,-0.915062
8,-0.856090,-1.013284
9,-0.843159,-1.111506
10,-0.805247,-1.203034
11,-0.744937,-1.281631
12,-0.558703,-1.467865
13,-0.372468,-1.654100
14,-0.186234,-1.840334
15,0.000000,-2.026568
Segments
1,1,2,0.134000
2,2,3,0.134000
3,3,4,0.134000
4,4,5,0.134000
5,5,6,0.134000
6,6,7,0.134000
7,7,8,0.134000
8,8,9,0.134000
9,9,10,0.134000
10,10,11,0.134000
11,11,12,0.134000
12,12,13,0.134000
13,13,14,0.134000
14,14,15,0.134000
End
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Currently there are many elements and node labels that make it difficult to understand what is going 

on. While not necessary, this tutorial will turn off the labels. Following these steps again would allow 

the user to put the labels back into the model.

1) From the View menu select Labels and submenu option Node #s.

2) From the View menu select Labels and submenu option Element #s.

Improving Visual
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1) From the Properties menu select Attach Section.

2) At the bottom menu bar, use the buttons to the right of Element(s): to make the list of elements.

3) Click the Adv button to open pop-up menu. Click the Reset button. To select both top chords, click 

the check box next to the X-axis option. Click the button to the right of Range (Inclusive) from Off

to On. Change the edit box to the left of Y to 8.

4) Click Add to add the top chord elements to the element list. 

5) Click on the Apply button to assign Section 1 to the top chord elements. 

6) Change the Section # by clicking on the current section number just to the right to open a pop-up 

menu with all section numbers. Click on 2 to select the “Bot Chord (V)” section. 

7) Select the Clr button located to the right of Elements: to clear the list of elements. 

8) Change the edit box to the left of Y to 0. Change the edit box to the right of Y to 8.

9) Click Add to add the bottom chord elements to the element list. 

10)Click on the Apply button to assign Section 2 to the bottom chord.

Section Properties – Assigning – 1
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1) Change the Section # by clicking on the current section number just to the right to open a pop-up 

menu with all section numbers. Click on 5 to select the “Web 3 (U)” section. 

2) Select the Clr button located to the right of Elements: to clear the list of elements. Click Reset at 

the bottom of the Advanced Element Section.

3) Click the check box next to X-axis and the check box next to Z-axis.

4) Click All to the right of Element(s): and then Remove to select all the webs.

5) Click on the Apply button to assign Section 5 to all webs temporarily.

6) Change the Section # by clicking on the current section number just to the right to open a pop-up 

menu with all section numbers. Click on 6 to select the “RIGID” section

7) Select the Clr button located to the right of Elements: to clear the list of elements. 

8) Click the check box next to X-axis. Z-axis should still be selected.

9) Click Add to select all the rigid connectors. Additionally click on the 4 vertical braces.

10)Click on the Apply button to assign Section 6 to the rigid connectors. 

Section Properties - Assigning – 2
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1) Change the Section # by clicking on the current section number just to the right to open a pop-up 

menu with all section numbers. Click on 4 to select the “Web 2 (U)” section. 

2) Select the Clr button located to the right of Elements: to clear the list of elements. 

3) Click on all the elements to be assigned Web 2 section properties.

4) Assign Section 4 properties by clicking the Apply button.

5) Change the Section # by clicking on the current section number just to the right to open a pop-up 

menu with all section numbers. Click on 3 to select the “Web 1 (U)” section. 

6) Select the Clr button located to the right of Elements: to clear the list of elements. 

7) Click on all the elements to be assigned Web 1 section properties.

8) Assign Section 3 properties by clicking the Apply button.

Section Properties - Assigning – 3
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1) From the Properties menu select Define Material.

2) At the bottom menu bar, click in the edit box just to the right of E= and change the 0 to 29000000

(not 29,000,000). Similarly, click in the edit box just to the right of Fy= and change the inf to 50000. 

Next, click in the edit box to the right of Name: and type Steel. Click on the Apply button (Material 

#1 is now defined with the properties of steel).

3) At the bottom menu bar, click in the edit box just to the right of E= and change the 0 to 

2900000000 (not 2,900,000,000). Next, click in the edit box to the right of Name: and type Rigid. 

Click on the Apply button. (Material #2 is now defined 100x stiffer and cannot yield.)

Material Properties
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1) From the Properties menu select Attach Material.

2) At the bottom menu bar, create the list of elements to be assigned the properties of Material 1 by 

clicking on the All button to the right of Elements:. Click on the Apply button. (Note that elements 

with assigned section and material properties turn solid.)

3) Change the Material # by clicking on the current material number just to the right to open a pop-up 

menu with all section numbers. Click on 2 to select the Rigid material. 

4) Select the Clr button located to the right of Elements: to clear the list of elements. 

5) Click the Adv button to open pop-up menu. Z-axis check box should be selected. 

6) Click Add to select all the rigid connectors. Additionally click on the 4 vertical braces. Clicking Adv

will close the pop-up menu making it easier to click all members.

7) Click on the Apply button to assign Material 2. 

Material Properties - Assigning
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1) From the Conditions menu select Define Fixities.

2) At the bottom menu bar, define the lateral support by clicking in the check box just to the left of Z-

disp. 

3) Click the Adv menu. Change the edit box to the left of Y from -Inf to 15. Change the edit box to the 

left of Z from -Inf to -0.1 and the edit box to the right of Z from Inf to 0.1. Click the Add button. 

4) From the View menu select Zoom Box. Click to draw a small box around the brace connection on 

the bottom chord at one end. Click on the middle node to add to the list of nodes.

5) From the View menu select Fit. From the View menu select Zoom Box. Click to draw a small box 

around the brace connection at the other end. Click on the middle node to add to the list of nodes.

6) Click on the Apply button.

7) From the View menu select Fit.

Support Conditions - Bracing
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1) To update the end nodes to provide pin supports, start by clicking Clr to empty the list of nodes.

2) From the View menu select Zoom Box. Click to draw a small box around the right roller node. It 

should currently just have a lateral support. Click on the node to add to the list of nodes.

3) Define a roller support by clicking in the check box just to the left of Y-disp. Z-disp should still be 

selected from before.

4) From the View menu select Fit.

5) Click on the Apply button.

6) From the View menu select Zoom Box. Click to draw a small box around the left pin node.

7) Click on the Clr button to empty the list of nodes. Click on the left pin.

8) Define a pin support by clicking in the check box just to the left of X-disp. Y-disp and Z-disp should 

still be selected from before.

9) From the View menu select Fit.

10)Click on the Apply button.

Support Conditions – Pin and Roller
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1) From the View menu select Labels and submenu option Element local (x’-y’-z’) axes. The purple 

line shows the positive x axis. The blue line shows the positive geometric y axis. The red line shows 

the positive geometric z axis. Based on the orientation of the angle sections as input, the y axis 

represents the direction from the centroid to the corner of the angle.

2) From the Geometry menu select Re-orient Element(s).

3) At the bottom menu bar, click in the edit box to the right of Beta (Deg) and change 0.0 to 135. 

4) Click the Adv button to open pop-up menu. Click the Reset button. To select the +z top chord 

angle, click the check box next to the X-axis option. Click the button to the right of Range 

(Inclusive) to On. Change the edit box to the left of Y to 8. Change the edit box to the left of Z to 0.

5) Click Add to add all these elements to the element list. Click on the Apply button to re-orient the 

elements.

6) Repeat this for the remaining 3 angle members orienting in the correct direction with the values 

shown in the table:

Chord Member Orientation

Member -Z Top +Z Bottom -Z Bottom

Beta -135 45 -45

Y-Range 8 to inf 0 to 8 0 to 8

Z-Range -2 to 0 0 to 2 -2 to 0

Side View

Iso. View
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Note: Due to the input orientation of the chord 
angles, the blue line illustrates a line from 
the heel of the angle through the centroid. 
The white angle outlines are shown just for 
reference. They are not part of the 
MASTAN2 interface.
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Based on the orientation of the web sections as input, the y axis points in the direction of the opening 

of the channel.

1) At the bottom menu bar, click in the edit box to the right of Beta (Deg) and update it to 180. 

2) On the Advanced Element Selection pop-up, click the Reset button. Click the check box next to the 

X-axis and Z-axis option. Create the list of webs to be flipped by clicking on the All button to the 

right of Elements:. Then click on Remove. 

3) Manually click the 4 vertical braces, the members assigned Web 2, and the vertical web to the right 

of center. 

Note: If you are having trouble seeing the webs that were unselected, look at the image associated with Step 5 

now. The same elements are still selected without all the local axes information on the screen. Also, available 

again is the diagram with web orientations. 

4) Click on the Apply button to re-orient the elements.

5) From the View menu select Labels and submenu option Element local (x’-y’-z’) axes. 

Web Member Orientation
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Web members highlighted in red do not need to be flipped as the sections were defined.
These are the members that are to be unselected.
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1) From the Geometry menu select Define Connections and submenu option Torsion.

2) At the bottom menu bar, click on the menu to the right of Warping Restraint for Node i and set the 

value to Continuous. Repeat this for the Warping Restraint for Node j. 

3) Click the Adv button to open pop-up menu. Unmark the check box next to the X-axis option. The 

check box next to the Z-axis option should still be selected. 

4) Create the list of elements to be assigned continuous warping by clicking on the All button to the 

right of Elements:. Then click on Remove. Click on the 4 vertical braces to remove them.

5) Click on the Apply button. 

Adding Warping Effects
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1) Click Clr to empty the list of elements. 

2) Click on the menu to the right of Warping Restraint for Node i and set the value to Free. Node j is 

set from a previous step. 

3) Click on the left most element of each chord. 

4) Click on the Apply button. 

5) Click Clr to empty the list of elements. 

6) Click on the menu to the right of Warping Restraint for Node i and set the value to Fixed. Node j is 

set from a previous step.

7) Click on the top end of all 15 web members

8) Click on the Apply button. 

Adding Warping Effects – Starting Node
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1) Click Clr to empty the list of elements. 

2) Click on the menu to the right of Warping Restraint for Node i and set the value to Continuous. 

Click on the menu to the right of Warping Restraint for Node j and set the value to Free. 

3) Click on the right most element of each chord.

4) Click on the Apply button. 

5) Click Clr to empty the list of elements. 

6) Click on the menu to the right of Warping Restraint for Node j and set the value to Fixed. Node i is 

set from a previous step.

7) Click on the bottom end of all 15 web members.

8) Click on the Apply button. 

Adding Warping Effects – Ending Node
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1) From the Geometry menu select Define Connections and submenu option Flexure.

2) At the bottom menu bar, click on the menu to the right of Type for Node i and set the value to 

Semi-Rigid. 

3) In the edit box to the right of kz change inf to 0.001. 

4) Click on the top end of all 15 web members to create the list of elements. 

5) Click on the Apply button.

6) Click on the menu to the right of Type for Node i and set the value to Rigid. Click on the menu to 

the right of Type for Node j and set the value to Semi-Rigid. 

7) In the edit box to the right of kz change inf to 0.001. 

8) Click Clr to empty the list of elements. 

9) Click on the bottom end of all 15 web members to create the list of elements. 

10)Click on the Apply button.

End Moment Release
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Section 5: Loading and Analysis



M
A

S
T
A

N
2

1) From the Conditions menu select Define Uniform Loads.

2) At the bottom menu bar, click on Element(s) local x’-y’-z’ to open the drop down menu. Select 

System global X-Y-Z. In the edit box just to the right of wy = change 0 to -12.5. 

3) Click the Adv button to open pop-up menu. Click the check box next to the Z-axis option to remove 

it. Click the check box next to the X-axis option. Click the Off button to the right of Range 

(Inclusive) to change it to On. Change the edit box to the left of Y to 8. 

4) Click Add to add the top chord elements to the element list. 

5) Click on the Apply button. The load will be split into the local element directions. 

6) From the View menu select Fit.

Distributed Loading
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1) From the Analysis menu select Static and submenu option 2nd-Order Elastic.

2) At the bottom menu bar, the Analysis Type: should already be set to Space Frame as desired. 

3) Click on the Apply button to perform the analysis. 

4) From the Results menu select Diagrams and submenu option Deflected Shape.

5) At the bottom menu bar, click on the Apply button.

To better see what deformation is occurring, it can be useful to make use of the other defined view. 

From the View menu select Defined Views and make use of the submenu options for these ideas. 

1) Option Front view: x-y.: How the vertical deflection is varying along the length

2) Option Side view: y-z.: How big the lateral deflection is compared to the joist

3) Option Top view: x-z.: How the lateral deflection varies along the length

4) Option Isometric: x-y-z.: Will return to the original view

It may be desired to update the deflected shape diagram with different scale factors during this 

process.

Uniform Loading Elastic Analysis
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1) From the Results menu select Node Displacements.

2) On the undeflected shape, click on the midspan node of interest, node 173, and the displacements 

for base 6 degree of freedoms are provided in the bottom menu bar. 

Calculated vertical deflection: 0.59 in

Estimated deflection using SJI recommendations:

𝐼𝑗 = 26.767 ∙ 𝑊 ∙ 𝐿3 ∙ 10−6 = 26.767 ∙ 297𝑝𝑙𝑓 ∙ 20𝑓𝑡 − 4𝑖𝑛 3 ∙ 10−6 = 60.47𝑖𝑛4

𝛿 = 1.15 ∙
5𝑊𝐿4

384𝐸𝐼
= 1.15 ∙

5 ∙ 300𝑝𝑙𝑓 20𝑓𝑡 − 4𝑖𝑛 4

384 ∙ 29000𝑘𝑠𝑖 ∙ 60.47𝑖𝑛4
= 0.66𝑖𝑛

Estimation using area of chords to calculate I:

𝐼𝐴 = 2 ∙ 0.29895𝑖𝑛2 ∙ 8.282𝑖𝑛 2 + 0.36199𝑖𝑛2 ∙ 15.121𝑖𝑛 − 8.282𝑖𝑛 2 = 74.87𝑖𝑛4

𝛿 = 1.15 ∙
5𝑊𝐿4

384𝐸𝐼
= 1.15 ∙

5 ∙ 300𝑝𝑙𝑓 20𝑓𝑡 − 4𝑖𝑛 4

384 ∙ 29000𝑘𝑠𝑖 ∙ 74.87𝑖𝑛4
= 0.53𝑖𝑛

3) From the Results menu select Element Forces.

4) On the undeflected shape, click on the span element of interest, element 204, and the internal 

forces are provided in the bottom menu bar. These are the forces at the start of the member.

Uniform Loading Results
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Section 6: Hanging Load Analysis
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1) From the Results menu select Diagrams and submenu option None.

2) From the Conditions menu select Define Forces.

3) At the bottom menu bar, click in the edit box just to the right of PY = and change 0 to -100 to create 

a handing load.

4) Click on the node at the tip of the eccentric arm created at the end of the geometry modeling, node 

232. 

5) Click on the Apply button. 

Eccentric Loading
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1) From the Analysis menu select Static and submenu option 2nd-Order Elastic.

2) At the bottom menu bar, the Analysis Type: should already be set to Space Frame as desired. 

3) Click on the Apply button to perform the analysis. 

Eccentrically Loaded Joist Elastic Analysis



M
A

S
T
A

N
2



M
A

S
T
A

N
2

1) From the Results menu select Node Displacements.

2) At the bottom menu bar, click on the Apply button.

3) On the undeflected shape, click on the midspan node of interest, node 173, to see how the change 

to the midspan deflection from the eccentric load.

4) On the undeflected shape, click on the node of the bottom chord attached to the eccentric loading 

arm, node 167, to see how the hanging load moved the chord.

Eccentrically Loaded Joist Elastic Results



M
A

S
T
A

N
2



M
A

S
T
A

N
2



M
A

S
T
A

N
2

Using the results available within the MASTAN2 model, it is possible to calculate the internal stresses 

that the members are experiencing. Provided in this tutorial are the steps to pull the necessary values 

from MASTAN2 and the resulting stresses. 

Additional details on the necessary calculations are available in the “Pour Stop” tutorial.

Stress Calculations
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1) From the Results menu select Element Forces.

2) On the undeflected shape, click on the midspan element of interest, element 198, and the internal 

forces are provided in the bottom menu bar. These are the forces at the start of the member and 

the middle of the beam. 

3) These forces will be used to calculate the stresses at the middle of the beam.

4) At the bottom menu bar, drag the slider in the over left-hand corner until the position indicator just 

to the right displays 1.00L. 

5) Click on the Apply button. These are the forces at the end of the member. 

6) From this position, the bimoment is required to appropriately divide the longitudinal moment into 

the standard twisting and warping components for stress calculations.

7) Repeat these steps to get the internal forces in element 192. This is where the larger negative 

moment on the bottom chord now occurs. 

The forces at the start: The forces at the end:

Getting Internal Forces
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At Joint Mid Span

Including 
Bimoment*

Excluding 
Bimoment*

The resulting stresses are available for the locations identified on the sketch. The forces are 

calculated immediately after the web connection node and after the point load.

Stress Calculation Results

* Numerically bimoment exists in the model because the warping constant, Cω, is non-zero. Additional meshing of the model 
would refine the distribution of bimoment, but bimoment would still exist locally in the model at applied torque or supports 
and rapidly decrease to approximately zero along the majority of the length of the bottom chord. Since the evaluation of 
angles would often excludes the effects of warping, the internal stresses are provided having been calculated using the 
forces observed in this model including and excluding the bimoment values. 
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Stresses at Joint including Bimoment
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Stresses at Joint excluding Bimoment
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Stresses at Midspan including Bimoment
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Stresses at Midspan excluding Bimoment
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This completes the tutorial.


